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1 Introduction 
  N2KAnalyzer® software is a powerful PC-based tool for analyzing, troubleshooting, and 
upgrading NMEA 2000 networks.  The   N2KAnalyzer® software, when installed on a Windows 
PC and used in conjunction with an intelligent NMEA 2000 gateway, such as the Maretron 
USB100, can be used to analyze the performance of NMEA 2000 networks, troubleshoot 
NMEA 2000 networks which are not functioning correctly, and update firmware on Maretron 
NMEA 2000 devices.   N2KAnalyzer® can be used on an operating NMEA 2000 network, 
whose state can be captured into a file and used for later analysis, or can be used offline to 
analyze the saved network state, allowing a user to save state of a network and send it to a 
technical expert for analysis. 
 
Features: 

• List all NMEA 2000 devices on the network 
• Display a wealth of following information for each device: 

o Node Address 
o Manufacturer 
o Manufacturer Model ID 
o Manufacturer Model 
o Manufacturer Serial Number 
o Source 
o Unique Instance 
o Label 
o Current Software 
o Available Software 
o Installation Description 
o Manufacturer Information 
o NMEA 2000 Device Function  
o NMEA 2000 Device Class 
o Manufacturer Model (Hardware) Version 
o NMEA 2000 Industry Group 
o NMEA 2000 Unique Number 
o NMEA 2000 Device Instance 
o NMEA 2000 System Instance 
o NMEA 2000 Product Code 
o NMEA 2000 Database Version 
o NMEA 2000 Certification Level 
o NMEA 2000 Load Equivalency 
o Transmitted PGN List 
o Received PGN List 

• For devices supporting multiple channels, display the following information for each 
device, as appropriate: 

o Hardware Channel 
o Indicator 
o Source 
o Instance 
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o Label 
• Display NMEA 2000 messages transmitted by each device in an easy-to-understand, 

human-readable format 
• Modify Installation Description information on devices which support user-programming 

of this information 
• Modify source and instance information on devices which support user-programming of 

this information 
• Analyze the devices on the network and their transmitted data to ensure that there are 

no instancing conflicts which can cause “bouncing needles” on displays 
• Program label information on devices which support user-programming of this 

information to assign meaningful text strings to every device and channel 
• Configure/Calibrate Maretron devices and select devices from other manufacturers 
• Update firmware on supported Maretron NMEA 2000 devices 
• Update  N2KAnalyzer® and its available firmware images over the internet 

2 System Requirements 
• Personal Computer running Microsoft Windows 2000, XP, or Vista 
• Gateway to NMEA 2000 Network (Maretron USB100) 
• 256 MB RAM 
• 30 MB Hard Disk Space 
• Internet connection 

3 Installation 
The  N2KAnalyzer® may be obtained by downloading from the Maretron website at 
http://www.maretron.com/downloads 
 
The installer for the  N2KAnalyzer® is packaged as an executable file.  To install  
N2KAnalyzer®, download the  N2KAnalyzer® installer from the internet at the link given above 
and save the executable file to your hard drive.  Then, run the  N2KAnalyzer® installer as you 
would any other program. 
 
The  N2KAnalyzer® Installer will display the following screen: 
 

http://www.maretron.com/downloads
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Figure 1 --  N2KAnalyzer® Installation Introduction Screen 

Click the Next button to continue. The  N2KAnalyzer® Installation program will then display the 
Select Destination Location screen. 
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Figure 2 -- Select Destination Location Screen 

By browsing or by typing in the name directly, enter then name of directory in which you wish 
the software to be installed, then click the Next button to continue to the next screen. 
 
The  N2KAnalyzer® Installer software will then display the Select Start Menu Folder screen.   
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Figure 3 -- Select Start Menu Folder Screen 

This screen gives you the opportunity to change the default start menu folder into which the  
N2KAnalyzer’s shortcuts will be placed. Once you are satisfied with the name of the start menu 
folder, click the Next button to continue.  The  N2KAnalyzer® installation program will then 
display the Select Additional Tasks screen. 
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Figure 4 -- Select Additional Tasks Screen 

This screen will allow you to choose optional tasks for the  N2KAnalyzer® Installation program 
to perform while it is installing the software. You may optionally select the creation of a desktop 
icon or a quick launch icon to start the  N2KAnalyzer® software in addition to the standard start 
menu launch item.  Once you have made your selections by clicking on the appropriate 
checkboxes, click the Next button to continue to the next screen. 
 
The  N2KAnalyzer® Installation software will then display the Ready to Install screen. 
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Figure 5 -- Ready to Install Screen 

This screen displays a summary of the options you have chosen up to this point in the 
installation process.  If you wish to change any options at this time, click the Back button which 
will take you back to previous screens in the installation process, where you may make the 
desired changes.  Once you are satisfied with the installation options you have chosen, click 
the Install button to begin copying the program files to the final locations. 
 
The  N2KAnalyzer® Installation software will display the Installing screen to show the status of 
the installation. 
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Figure 6 -- Installing Screen 

Once the installation of the software is finished, the  N2KAnalyzer® Installation program will 
display the Completing the  N2KAnalyzer Setup Wizard screen. 
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Figure 7 -- Completing the Maretron  N2KAnalyzer® Setup Wizard Screen 

This screen gives you the option to launch the  N2KAnalyzer® software. Click the “Launch  
N2KAnalyzer®” checkbox if you wish to start the  N2KAnalyzer® software after the installation 
process is complete. 
 
This screen also gives you the option to read the  N2KAnalyzer® User’s Manual.  Click the 
“Read User’s Manual” checkbox if you wish to open the  N2KAnalyzer® User’s Manual after the 
software installation process is complete. 
 
Finally, click the Finish button to complete the software installation process.  The  
N2KAnalyzer® software is now ready to use. 

4 Tutorial 

4.1 Starting the software 
You may start the  N2KAnalyzer® software in one of three ways: 

• Selecting the All Programs→Maretron  N2KAnalyzer menu item from the Start Menu 
• Clicking the quick launch icon, if you requested one to be created during installation, or 
• Clicking the desktop icon, if you requested one to be created during installation, 

4.2 Connecting to a NMEA 2000 Network 
When you start the  N2KAnalyzer® software, the software will look for a NMEA 2000 gateway. 
If it finds a single gateway, or if the gateway you used previously is available, the  
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N2KAnalyzer® software will ask you if you wish to connect to the NMEA 2000 network using 
that gateway. 
 

 
Figure 8 --  N2KAnalyzer® Connect Screen 

If no connected gateways are detected on the computer, you are given the option to connect a 
gateway and retry the gateway detection process by clicking the OK button, or you may 
continue the program without going online (for example, to examine a previously saved boat 
file) by clicking the Cancel button. 
 

 
Figure 9 -- Screen Displayed When No Gateways are Detected 

If you choose to connect a gateway, then after you connect the gateway and press the OK 
button, you are presented with the Configure Gateway dialog box in order to confirm your 
gateway selection.  
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Figure 10 -- Gateway Configuration Screen 

Click on the desired gateway to select it, and then click on the OK button to confirm your 
selection and enter online mode. 

4.3 Viewing Device Information 
Once the  N2KAnalyzer® software has connected to the N2K network, or if the  N2KAnalyzer® 
software is operating disconnected from the N2K network with a loaded boat file, then the 
device list window is filled with information about the NMEA 2000 devices on the bus. 
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Figure 11 -- Main Program Window 

 

4.4 Boat Files 
 N2KAnalyzer® has the capability to store the state of a network and all of its devices to an 
external file, and also to load the state of a network and all of its devices from an external file. 
These files are called “boat files”, and are usually named with the name of the vessel followed 
by a “.net” extension.  If you are on a vessel with some NMEA 2000-related issue, you can 
start  N2KAnalyzer® and save a boat file, which you can then e-mail or otherwise transfer to 
someone at a remote location for analysis. 

4.4.1 Loading a Boat File 
While working disconnected from the NMEA 2000 bus, you may load a boat file that was saved 
previously and examine its contents using the  N2KAnalyzer® software.  Selecting the File-
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>Open… menu option or clicking on the Open File toolbar button will cause the following dialog 
screen to be displayed. 
 

 
Figure 12 -- Boat File Open Dialog Box 

 
Browse to the boat file you wish to load or type in the name of a boat file you wish to load and 
then click the Open button to cause the boat file to be loaded. 

4.4.2 Saving a Boat File 
While connected to a NMEA 2000 bus, you may wish to save information about the network so 
that you or someone else can analyze it later using the  N2KAnalyzer® software. Selecting the 
File->Save As… menu item will cause the File Save dialog box to be displayed and will cause 
all currently available network information to be saved to a boat file.  
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Figure 13 -- Boat File Save Dialog Box 

Browse to the directory in which you wish to save the boat file, and then type the desired 
filename under which to save the boat file. Finally, click the Save button to save the file to the 
hard drive. 

4.5 Updating Software on a Device 
If the  N2KAnalyzer® software has a version of software for a device that is newer than the 
version currently on the device, then the version number in the Current Software column of the 
device list window will be highlighted in red.  You can update the software on the device to the 
latest available version in one of two ways: 

• Select the device in the device list window by clicking on it, and then select the Update-
>Selected Device’s Software… menu item, or 

• Select the device in the device list window by clicking on it, and the right-click on the 
device and select the Update Selected Device’s Software menu item from the pop-up 
context menu that appears. 

Once the update process starts, the  N2KAnalyzer® software will display a window describing 
the status of the device software update process. 
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Figure 14 -- Firmware Update Progress Window 

Once the firmware update process has completed, the  N2KAnalyzer® software will then 
display another window summarizing the results of the firmware update process. 
 

 
Figure 15 -- Firmware Update Summary Window 

4.6 Viewing Device Properties 
In order to view more information about a device than is displayed in the device list window, 
select the device in the device list window and then either select the Analyze->Device 
Properties menu item or right-click on the highlighted device and select Device Properties from 
the pop-up context menu that appears as a result. 
 
The Device Properties window has three tabs: General, Transmit PGN List, and Received 
PGN List.  The General tab is shown in the figure below. 
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Figure 16 -- Device Properties Window: General Tab 

The General tab displays the following information: 
• Node Address – Each device on an NMEA 2000 network claims a node address 

between the value of 0 (0x0 hexadecimal) and 251 (0xFB hexadecimal). These node 
addresses may change as new devices are added to the network. This column shows 
the node addresses claimed by the device. 

• Mfg Model ID – This shows the Device Model (sometimes known as Model ID, Model 
Number, or Model Name) reported by the device. 

• Mfg Serial Number – This shows the serial number reported by the device. 
• Mfg Model Version – This shows the hardware version number reported by the device. 
• Current Software – This shows the firmware version number reported by the device. 
• Manufacturer – This column shows the manufacturer reported by each device.  The 

manufacturer’s names are read from a table in the  N2KAnalyzer® software which 
translates the manufacturer’s code reported by the device.  If a new NMEA 2000 
manufacturer has been added since the  N2KAnalyzer® software was release, this will 
show up as a numeric value. If this happens, please either 

o Update your  N2KAnalyzer® software, or 
o Check the NMEA website for the current list of manufacturer codes. 
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• Industry Group – This shows the industry group reported by the device. Maretron 
products are in the Marine industry group.  Device Class and Device Function 
definitions depend on the value on this field. 

• Device Class – This shows the NMEA 2000 device class as reported by the device. 
• Device Function – This shows the NMEA 2000 device function (this is a more-specific 

indication of the device function within the context of the device class) reported by the 
device. 

• Unique Number – This shows a number for the specific device. The combination of this 
number, the Device Class, and the Device Function are guaranteed to be unique. 

• Device Instance – This shows the electronic control instance number.  This is used by 
some receiving devices to distinguish one set of data from another. 

• System Instance – This shows the system instance number. This is used by some 
receiving devices to distinguish one group of devices of data from another. 

• Mfg Product Code – This shows the NMEA 2000 product code for the device.  This 
number uniquely identifies the manufacturer and model of the device. 

• N2K Database Version – This shows the version of the NMEA 2000 database that is 
supported by this device. 

• N2K Certification Level – This shows the certification level of this device.  Current 
certification levels are “A” and “B”. 

• LEN (Load Equivalency Number)  – This shows the number of loads that this device 
presents to the network.  This can be used for power supply and cable sizing.  Each 
load represents 50 mA of current consumption.  

 
The Transmit PGN List shows a list of the messages that this device can transmit. This 
function is required for devices with Certification Level “A”.  Devices with Certification Level “B” 
may not transmit this information. 
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Figure 17 -- Device Properties Window: Transmit PGN List Tab 

The Receive PGN List shows a list of the messages that this device is capable of recognizing. 
This function is required for devices with Certification Level “A”.  Devices with Certification 
Level “B” may not transmit this information. 
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Figure 18 -- Device Properties Window: Received PGN List Tab 

4.7 Configuring Devices 
 N2KAnalyzer® allows you to configure information common to all devices directly in the device 
list, much as you would edit a spreadsheet. Items in the device list which you can change have 
a white background.  
 
For more detailed configuration, you may configure devices using the built-in DSM250 
emulator, which you can access by selecting the Analyze->DSM250 Viewing… menu item.  
This emulator operates exactly the same as the Maretron DSM250 Multifunction Display, and 
is shown in Figure 19 below. Please refer to the Maretron DSM250 Multifunction Display 
User’s Manual for details on configuring particular devices. 
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Figure 19 – DSM250 Viewing Window 

4.8 Viewing and Changing Installation Description 
 

You can view and change the installation description information which can be 
programmed into NMEA 2000 devices which support this capability by selecting the 
Configure->Installation Descriptions menu item.  The Installation Descriptions dialog box  
shows the Installation Description #1 and Installation Description #2 fields. These are free-
form text fields that may be programmed by the installer in devices that support field 
programming of this information.  To set the value of one of these fields, type the desired 
information into the text box and click the OK button once you are finished.  This will cause 
the entered value to be permanently programmed into the device’s non-volatile memory. 
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Figure 20 -- Device Properties Window: Installation Description Tab 

4.9 Viewing NMEA 2000 Messages 

4.9.1 Using the Transmitted PGNs Window 
You can view the messages transmitted by a particular device on the network by first left-
clicking on the device in the device list window, and then either selecting the Analyze-
>Transmitted PGNs menu item or by right-clicking on the device and selecting the Analyze 
Transmitted PGNs menu item from the pop-up context menu.  A window appears listing the 
PGN’s transmitted by the device.  The contents of the window are updated in real time. The 
messages appear one line per message. You can click on the “+” icon on the left side of the 
message to expand it and show the contents of the individual message fields.  Click once more 
to collapse the message display into a single line. 
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Figure 21 -- Transmitted PGNs Window 

4.10 Analyzing NMEA 2000 Instancing 
When configuring an NMEA 2000 network, it is important to ensure that all devices transmitting 
the same type of information (for example, Fuel tank level) are programmed with distinct 
instance numbers.  This is so that a display device can correctly identify the source of the 
measurement. 
 
There may be some cases where two devices with the same instance numbers is desirable, 
specifically, when redundancy is desired.  For example, you may choose to install two GPS 
antennas for redundancy. In that case, if both GPS antennas  
 
 N2KAnalyzer® is capable of analyzing the device information and network traffic to determine 
whether any conflicts exist.  You can run this analysis function be selecting Analyze-
>Instancing menu item.  After you select that menu item, you will see an introductory dialog 
box (shown in  Figure 22). 
 

 
Figure 22 - Instancing Analyzer Introductory Dialog 
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Click the “OK” button to begin the analysis. Once you click “OK”, the dialog will close and the 
Instancing Analysis Results Window will appear. It will display any detected instancing conflicts 
as they occur, along with recommended actions to resolve the conflicts.  The results window is 
shown in Figure 23 below. 
 

 
Figure 23 - Instancing Analysis Results Window 

The analysis will complete after 30 seconds have elapsed. Once the analysis has completed, a 
dialog box will appear indicating whether or not any conflicts were detected.  Click the “OK” 
button to close the dialog box (shown in Figure 24 below). 
 
 

 
Figure 24 - Instancing Analysis Errors Detected Dialog 

Once you have completed instancing analysis, resolve any undesired conflicts by either 
performing the recommended actions, or by changing instance numbers and/or source types.  
Repeat this entire process until you do not have any unexpected conflicts. 
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5 Window Elements 

 
Figure 25 -- Window Elements 

The following window elements are present in the  N2KAnalyzer® software: 
• Menu 
• Toolbar 
• Device List Window 
• Status Bar 

5.1 Menus 

5.1.1 File 

5.1.1.1 Open... 
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5.1.1.2 Save As... 
Opens a window which allows you to choose the filename to which to save a "boat file".  The 
“boat file” contains the current state of the network you are monitoring. 

5.1.1.3 Print… 
Prints the current contents of the Device List Window to a printer. 

5.1.1.4 Connect to NMEA 2000 Network 
Connects  N2KAnalyzer® to the NMEA 2000 network through the currently selected NMEA 
2000 gateway, and queries the attached NMEA 2000 network for devices and fills the device 
list table with this information. 

5.1.1.5 Disconnect from NMEA 2000 Network 
Disconnects  N2KAnalyzer® from the NMEA 2000 gateway.  All information that was previously 
available from the attached NMEA 2000 network which  N2KAnalyzer® was in online mode is 
still available. 

5.1.1.6 Refresh 
Refreshes the device list window by asking all devices on the NMEA 2000 network to transmit 
their information. 

5.1.1.7 Exit 
Changes from online mode to offline mode, if necessary, and exits  N2KAnalyzer® completely. 

5.1.2 Setup 

5.1.2.1 Software Update Directory... 
This opens a dialog box allowing you to select the directory which contains the software image 
files to use when updating Maretron equipment on the attached NMEA 2000 network. 

5.1.2.2 Configure Gateway... 
This opens a dialog window allowing you to select a specific NMEA 2000 gateway to connect 
to when entering online mode. 
 

5.1.2.3 Download Software Updates On Startup 
If checked, this selection causes  N2KAnalyzer® to check for new versions of the program and 
device software every time it is started.  If desired, you can disable this behavior by clicking on 
this selection to clear the checkmark.  In either case, you can manually check for updates at 
any time by clicking on the Web->Download Software Updates menu selection. 

5.1.2.4 Recover Device 
It is possible, but extremely rare, for a device to get into a state in which it cannot be accessed 
by  N2KAnalyzer® in normal mode. An example of this is a device which is being programmed 
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with new firmware, and the firmware update process is aborted or fails for some reason. 
Subsequently, when you need to re-program the device, you are asked for a part number. If 
you supply the wrong part number, the device will get flashed with firmware intended for 
another device.  The device will then appear unresponsive on the network.  You can use the 
“Recover Device” menu option to place the device into a state in which you can program it with 
the correct firmware release. 

5.1.2.5 Show Tips on Startup 
If checked, this selection causes  N2KAnalyzer® to display a “tip of the day” when started. 

5.1.2.6 Columns 
The columns selection opens a submenu which lists all of the available columns that can be 
displayed in the device list window.  The columns that are currently enabled for display are 
denoted by a checkmark.  To enable or disable a column for display, click on it in this menu. 

5.1.3 Analyze 

5.1.3.1 Received PGNs 
This opens a window displaying the PGN’s that the device reports as being able to receive, 
including a description of all the data fields. 

5.1.3.2 Transmitted PGNs 
This opens a window displaying the transmitted PGN's from the selected device, including a 
timestamp and a description of all the data fields. 

5.1.3.3 Device Properties 
This opens a window displaying information on the selected device, including general 
properties, the installation description fields, and a list of pgns that the device reports that it 
transmits and receives. 

5.1.3.4 Instancing 
This causes  N2KAnalyzer® to scan the network information and traffic, searching for 
conflicting instancing information that may cause displays to report incorrect information.  It will 
open a window that will display conflicts and recommendations for resolving the conflicts. 

5.1.3.5 DSM250 Viewing… 
This opens a window containing an emulation of the Maretron DSM250 Multi-function display, 
which allows you to view a wide variety of data on the attached NMEA 2000 network.  This 
menu item is available only in online mode. 
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5.1.4 Update 

5.1.4.1 Selected Device’s Software... 
This will update the softwareware on the device that has been highlighted in the device list 
window to the most recent version. This menu item is available only in online mode. 

5.1.5 Configure 

5.1.5.1 Installation Descriptions 
This will enable you to change the installation descriptions fields of the selected device, 
provided that the device supports field modification of these fields.  You can fill these fields 
with any desired data; for example, the location of the device, date installed, date calibrated, 
etc. 

5.1.5.2 Device Instance 
This will enable you to change the upper device instance and lower device instance fields of 
the device, provided that the device supports modification of these fields over the network 
(some devices provide instead the ability to modify these fields by DIP switches or rotary 
switches on the devices themselves; please consult the device’s user manual for details). 

5.1.5.3 DSM250 Configuration… 
This opens a window containing an emulation of the Maretron DSM250 Multi-function display 
in configuration mode, which allows you to configure any Maretron devices on the attached 
NMEA 2000 network.  Please refer to the DSM250 User’s Manual for detailed instructions on 
configuration of  NMEA 2000 devices. This menu item is available only in online mode. 

5.1.5.4 Restore Factory Defaults 
This will return the currently selected device to the condition it was in when it was shipped from 
the factory, except that the device will retain its current node address. 

5.1.6 Web 

5.1.6.1 Download Software Updates 
Connects to the Maretron website and checks whether a newer version of  N2KAnalyzer® 
software or updates to device software are available.  If newer software is available,  
N2KAnalyzer® will prompt you to download and install the new version. 

5.1.6.2 Maretron Website 
Opens your default web browser and directs it to the Maretron home page, where you can find 
information about Maretron products and solutions. 
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5.1.6.3 Knowledge Base 
Opens your default web browser and directs it to Maretron’s support knowledge base, where 
you can find answers to questions about the installation, configuration, and use of Maretron 
products. 

5.1.7 Help 

5.1.8 User’s Manual 
Displays this user’s manual. 

5.1.9 About  N2KAnalyzer® 
Displays a dialog box with information about  N2KAnalyzer®, including the current version 
number and copyright information. 

5.2 Toolbar  
 

  
Figure 26 – Toolbars 

The following icons appear on the toolbar, in order from left to right: 
- Open (same as File->Open…):  Loads a network configuration from a boat file. 
- Save (same as File->Save As…):  Saves the current network configuration to a boat 

file. 
- Print:  Prints the contents of the Device List Window. 
- Connect/Disconnect:  Connects  N2KAnalyzer® to a NMEA 2000 network if it is 

currently disconnected from the network, and vice versa. 
- Refresh:  Causes  N2KAnalyzer® to refresh the state of the Device List window. 
- Web:  This feature is not yet implemented. 
- About:  Displays the About window. 

5.3 Device List Window 
 
The device list window shows information on all devices currently connect to the NMEA 2000 
network.  The  N2KAnalyzer® software broadcasts a request to all nodes on the NMEA 2000 
network, which in turn broadcast their identifying information.  It then fills the device list window 
with information as it is received from the other devices on the network. This process repeats 
every ten seconds, and the device list window contents are updated accordingly. 
 
The text for each device is normally displayed in black. Different colors are used to signify 
different characteristics of devices: 

• Blue – identifies the gateway that is being used by the  N2KAnalyzer® software 
• Red – identifies that a new revision of firmware is available for that device. 
• Grey – device is not responding or has been removed from the network. 
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Some parameters of devices, including the Unique Instance, Label, Installation Description #1 
and Installation #2, can be edited directly in the device list window, just as you might do with a 
spreadsheet program.  The device parameters that can you can change have a white 
background, as opposed to device parameters that are not user-changeable, which have a 
yellow background. 

 
Figure 27 -- Device List Window 

5.3.1 Expand 
Some NMEA 2000 devices can transmit more than one distinct parameter (this is referred to 
as having multiple hardware channels). If a particular device can display more than one 
parameter, a “+” sign appears in the “Expand” column of the screen.  You can click on this “+” 
sign, and the single device row will expand to add a row for each hardware channel in the 
device. 

5.3.2 Node Address 
Each device on an NMEA 2000 network claims a node address between the value of 0 (0x0 
hexadecimal) and 251 (0xFB hexadecimal). These node addresses may change as new 
devices are added to the network. This column shows the node addresses claimed by each 
device on the network. 
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5.3.3 Manufacturer 
This column shows the manufacturer reported by each device.  The manufacturer’s names are 
read from a table in the  N2KAnalyzer® software which translates the manufacturer’s code 
reported by the device.  If a new NMEA 2000 manufacturer has been added since the  
N2KAnalyzer® software was released, this will show up as a numeric value. If this happens, 
please either 

• Update your  N2KAnalyzer® software by selecting Web->Download Firmware Updates 
menu item, or 

• Check the NMEA website for the current list of manufacturer codes. 

5.3.4 Mfg Model ID 
This column shows the model ID (sometimes known as Device Model, Model Number, or 
Model Name) reported by each device. 

5.3.5 Mfg Model Version 
This column shows the hardware version number reported by each device. 

5.3.6 Mfg Serial Number 
This column shows the serial number reported by each device. 

5.3.7 Source 
This column shows the source type for the device, if the device has a single hardware channel 
and a source type. Currently, Maretron TLA (Tank Level Adapter) and TLM (Tank Level 
Monitor) devices fall into this category. 

5.3.8 Unique Instance 
This column shows the Unique Instance for the device.  The Unique Instance is the instance 
number that is used to identify the device in N2KView or DSM250. It may correspond to the 
device instance or to a channel instance, depending on the device. 

5.3.9 Current Software 
This column shows the software version number reported by each device. 

5.3.10 Available Software 
This column shows the most recent version of software that is available for each device that 
can be updated by the  N2KAnalyzer® software.  This number will be highlighted in red if it is 
newer than the version of the firmware currently installed on the device. If this number is lower 
than the version number shown in the Current Software column, then please download a more 
recent copy of  N2KAnalyzer® from http://www.maretron.com/downloads. 

5.3.11 Install Description #1 
This column shows the “Install Description #1” field of the Product Information message, which 
is user-programmable in some devices and may be used by a user to describe various 
information; for example, the location of the equipment. 

http://www.maretron.com/downloads
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5.3.12 Install Description #2 
This column shows the “Install Description #2” field of the Product Information message, which 
is user-programmable in some devices and may be used by a user to describe various 
information; for example, the location of the equipment. 

5.3.13 Mfg Information 
This column shows the Manufacturer’s Information field of the Product Information, which is 
programmed by a device manufacturer to describe various information; for example, contact 
information for the manufacturer. 

5.3.14 Device Class 
This column shows the NMEA 2000 device class as reported by each device. 

5.3.15 Device Function 
This column shows the NMEA 2000 device function (this is a more-specific indication of the 
device function within the context of the device class) reported by each device. 

5.3.16 Device Instance 
This column shows the NMEA 2000 device instance reported by each device. 

5.3.17 System Instance 
This column shows the NMEA 2000 system instance reported by each device. 

5.3.18 NMEA 2000 Version 
This column indicates the version of the NMEA 2000 standard to which the device was 
designed. 

5.3.19 NMEA 2000 Certification Level 
This column indicates the level of network functionality implemented by the device. Current 
values include “A”, which indicates full functionality, and “B”, which indicates resuced 
functionality. 

5.3.20 MFG Product Code 
This column indicates the numeric product code assigned to the device by NMEA. 

5.3.21 LEN 
This column indicates the Load Equivalent Number reported by the device.  Each LEN 
indicates 50mA current consumed by the device.  For example, a device with LEN equal to 3 
will consume a maximum of 150mA current.  This information is required for network cabling 
and power supply planning. 

5.4 Device Channel Information 
If a device supports multiple hardware channels, clicking on the “+” symbol in the “Expand” 
column will open another grid showing information for the hardware channels. This window will 
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contain different information depending on the device. Following is a list of columns that are 
supported: 

5.4.1 Hardware Channel 
This column identifies which hardware channel the information in that row is for.  For some 
types of devices, this column will contain a number corresponding to the number of the 
hardware channel the information is for.  For other devices, this column may contain a text 
string describing the function of the channel. 

5.4.2 Indicator 
For RIM and SIM devices, this column contains the number of the indicator the information in 
that row is for. 

5.4.3 Source 
For hardware channels which indicate a source type, this column contains the name of the 
source type currently selected for that channel. 

5.4.4 Instance 
For channels which indicate a numeric instance, this column contains the number of the data 
instance currently selected for that channel. 

5.4.5 Label 
This column contains the text label which is assigned to that channel.  This label will appear in 
N2KView and DSM250 when you are selecting parameters to display in a component or on a 
favorite screen. 

5.5 Status Bar 
The status bar at the bottom of the main program window displays information about the 
current operating mode of the  N2KAnalyzer® software. 
 

 
Figure 28 -- Status Bar 

5.5.1 Status Message Area 
This area displays the current status of the  N2KAnalyzer® software, as well as help for toolbar 
buttons over which the mouse cursor is located. 

5.5.2 Connection Status Indicator 
This area displays “Connected to NMEA 2000 Network” if the  N2KAnalyzer® software is 
currently connected to a NMEA 2000 network through a gateway, and “Disconnected from 
NMEA 2000 Network” at all other times. 
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5.5.3 COM Port Selection Indicator 
If the  N2KAnalyzer® software is operating in online mode, then this area of the status bar will 
display the name of the serial port (COM port) being used to connect to the NMEA 2000 
gateway. 

5.5.4 Caps Lock Indicator 
This area of the status bar displays “CAP” if caps lock is active on the keyboard, and is blank 
otherwise. 

5.5.5 Num Lock Indicator 
This area of the status bar displays “NUM” if num lock is active on the keyboard, and is blank 
otherwise. 

5.5.6 Scroll Lock Indicator 
This area of the status bar displays “SCRL” if scroll lock is active on the keyboard, and is blank 
otherwise. 

6 Troubleshooting 
SYMPTOM: When trying to enter online mode, you see a dialog box with the message ‘Failure 
to connect to NMEA 2000 Gateway on port “COMx”’. 
 
This message indicates that the  N2KAnalyzer® software was unable to establish a connection 
to the NMEA 2000 network through the NMEA 2000 gateway on the indicated serial port. 
Following are some steps you can take to resolve the problem. 
 

• Select the Setup->Configure Gateway… menu item to select a valid NMEA 2000 
gateway. 

• Check that the NMEA 2000 gateway is connected to a powered NMEA 2000 network 
and is receiving power through the NMEA 2000 network connection. 

• Check that the NMEA 2000 gateway is connected to the computer and that the 
connecting cable is good.  Try reconnecting the NMEA 2000 gateway to the computer 
with a different cable. 

• Check the security of all NMEA 2000 network connections. 
• Try disconnecting and reconnecting the cable between the computer and the NMEA 

2000 gateway. 
• Reboot the computer. 

 
SYMPTOM: You see only the NMEA 2000 Gateway in the device list window. This means that 
the NMEA 2000 Gateway is properly connected to the computer, but is unable to communicate 
with other NMEA 2000 devices.  Following are some steps you can take to resolve the 
problem, 
 

• Ensure that the proper drivers are installed for the NMEA 2000 gateway. 
• Check that the NMEA 2000 network has two termination resistors installed. 



   
 

   
Revision 1.4.0  Page 37 

®®

• Check the security of all NMEA 2000 network connections. Ensure that at least one 
other device is connected to the NMEA 2000 network. 

7 Technical Support 
If you require technical support for Maretron products, you can reach us in any of the following 
ways: 
 Telephone: 1-866-550-9100 
 Fax: 1-602-861-1777 
 E-mail: support@maretron.com 
 World Wide Web: http://www.maretron.com 
 Mail: Maretron, LLP 
  Attn: Technical Support 
  9014 N. 23rd Ave Suite 10 
  Phoenix, AZ 85021 USA 

mailto:support@maretron.com
http://www.maretron.com/
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